Как сделать чтобы шапка печаталась на каждой

Как сделать чтобы шапка печаталась на каждой
Как сделать чтобы шапка печаталась на каждой

777нуждаюсь в помощи!!!
Guest Привет! Документ на нескольких листах, как сделать чтобы шапка печаталась на каждом листе? а то у меня она выводится только на первом... 777нуждаюсь в помощи!!!
Guest Выдает ошибку - что не правильно?
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
ОбластьРЭС = Макет.ПолучитьОбласть("РЭС");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

ТабДок.Очистить();
ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаРЭС = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

Пока ВыборкаРЭС.Следующий() Цикл
ОбластьРЭС.Параметры.Заполнить(ВыборкаРЭС);
ТабДок.Вывести(ОбластьРЭС, ВыборкаРЭС.Уровень());

ВыборкаДетали = ВыборкаРЭС.Выбрать();

Пока ВыборкаДетали.Следующий() Цикл
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетали);
ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетали.Уровень());
КонецЦикла;
КонецЦикла;

ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.Вывести(ОбластьПодвалТаблицы);
ТабДок.Вывести(ОбластьПодвал);
ТабДок.ПовторятьПриПечатиСтроки = ТабДок.ОбластьШапкаТаблицы;

777нуждаюсь в помощи!!!
Guest Надо каким-то образом сделать ВыводНаКаждойСтранице, но где указать и как не знаю. ПОМОГИТЕ!!!! pail
Member
Откуда: Екатеринбург
Сообщений: 979
сказать
ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы; 777нуждаюсь в помощи!!!
Guest pail сказать
ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;
Не срабатывает Стильный Бабер
Member [заблокирован]
Откуда:
Сообщений: 224
так, конешно.. нада вот так сказать ..
ТабДок.ПовторятьПриПечатиСтроки("пожалуйста") = ОбластьШапкаТаблицы; 777нуждаюсь в помощи!!!
Guest Стильный Бабер так, конешно.. нада вот так сказать ..
ТабДок.ПовторятьПриПечатиСтроки("пожалуйста") = ОбластьШапкаТаблицы;
Забавно, но я ведь не шучу, по тексту программы видно что написано, тем более в программе я удалили ТабДок чтобы получить именно то что советовал pail, макет был сформирован при помощи Конструктора выходных форм при создании отчета Стильный Бабер
Member [заблокирован]
Откуда:
Сообщений: 224
Что хоть за ошибка? Сделай по образцу.

ТабДок = новый ТабличныйДокумент;
Макет = ПолучитьМакет("Макет");
Область = Макет.ПолучитьОбласть("Обл");
....

ТабДок.Вывести(Область);
....
НаПринтер = Ложь;
КоличествоЭкземпляров = 1;
НапечататьДокумент(ТабДок, КоличествоЭкземпляров, НаПринтер,);

777нуждаюсь в помощи!!!
Guest Стильный Бабер Что хоть за ошибка? Сделай по образцу.

ТабДок = новый ТабличныйДокумент;
Макет = ПолучитьМакет("Макет");
Область = Макет.ПолучитьОбласть("Обл");
....

ТабДок.Вывести(Область);
....
НаПринтер = Ложь;
КоличествоЭкземпляров = 1;
НапечататьДокумент(ТабДок, КоличествоЭкземпляров, НаПринтер,);


Самое прикольное что нет никакой ошибки - прога как будто игнорирует эту строку, просто не выводит на каждой странице заголовок и все, я 1С8-ку совсем плохо знаю может ли это быть из-за того что выполняется запрос с группировками? (запрос объединяет 2 запроса), вот как у меня:
Макет = ОтчетОбъект.ПолучитьМакет("Запрос777");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
...
Результат = Запрос.Выполнить();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы"); Область1 = Макет.ПолучитьОбласть("1");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

ТабДок.Очистить();
ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаТаблицы); ТабДок.НачатьАвтогруппировкуСтрок();

Выборка1 = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока Выборка1.Следующий() Цикл
ОбластьРЭС.Параметры.Заполнить(ВыборкаРЭС);
ТабДок.Вывести(ОбластьРЭС, ВыборкаРЭС.Уровень());

ВыборкаДетали = ВыборкаРЭС.Выбрать();

Пока ВыборкаДетали.Следующий() Цикл
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетали);
ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетали.Уровень());
КонецЦикла;
КонецЦикла;

ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.Вывести(ОбластьПодвалТаблицы);
ТабДок.Вывести(ОбластьПодвал);
ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;
ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабДок.НижнийКолонтитул.Выводить = Истина;
ТабДок.НижнийКолонтитул.НачальнаяСтраница = 1;
ТабДок.НижнийКолонтитул.ТекстСправа =[&НомерСтраницы]"+" из "+"[&СтраницВсего]";

//}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ
вот почему не хочет выводить? и никаких ошибок... просто как будто нет этой записи

777нуждаюсь в помощи!!!
Guest Помогите изменить макет чтобы печаталась шапка:
Процедура ТипыСчетчиковОбщееСортирвка(ТабДок) Экспорт
//{{КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ(ТипыСчетчиковОбщееСортирвка)
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Макет = ОтчетОбъект.ПолучитьМакет("ТипыСчетчиковОбщееСортирвка");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|......
|АВТОУПОРЯДОЧИВАНИЕ";

Результат = Запрос.Выполнить();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
ОбластьОбщийИтог = Макет.ПолучитьОбласть("ОбщиеИтоги");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

ТабДок.Очистить();
ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаОбщийИтог = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

ВыборкаОбщийИтог.Следующий(); // Общий итог
ОбластьОбщийИтог.Параметры.Заполнить(ВыборкаОбщийИтог);
ТабДок.Вывести(ОбластьОбщийИтог, ВыборкаОбщийИтог.Уровень());

ВыборкаДетали = ВыборкаОбщийИтог.Выбрать();

Пока ВыборкаДетали.Следующий() Цикл
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетали);
ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетали.Уровень());
КонецЦикла;

ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.Вывести(ОбластьПодвалТаблицы);
ТабДок.Вывести(ОбластьПодвал);
//Без конструктора
//ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;
// ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабДок.НижнийКолонтитул.Выводить = Истина;
ТабДок.НижнийКолонтитул.НачальнаяСтраница = 1;
// ТабДок.НижнийКолонтитул.ТекстСлева = " № " + Номер;
ТабДок.НижнийКолонтитул.ТекстСправа = "стр. "+"[&НомерСтраницы]"+" из "+"[&СтраницВсего]";

//}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ

777нуждаюсь в помощи!!!
Guest 777нуждаюсь в помощи!!! Помогите изменить макет чтобы печаталась шапка:
Процедура ТипыСчетчиковОбщееСортирвка(ТабДок) Экспорт
//{{КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ(ТипыСчетчиковОбщееСортирвка)
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Макет = ОтчетОбъект.ПолучитьМакет("ТипыСчетчиковОбщееСортирвка");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|......
|АВТОУПОРЯДОЧИВАНИЕ";

Результат = Запрос.Выполнить();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
ОбластьОбщийИтог = Макет.ПолучитьОбласть("ОбщиеИтоги");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

ТабДок.Очистить();
ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаОбщийИтог = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

ВыборкаОбщийИтог.Следующий(); // Общий итог
ОбластьОбщийИтог.Параметры.Заполнить(ВыборкаОбщийИтог);
ТабДок.Вывести(ОбластьОбщийИтог, ВыборкаОбщийИтог.Уровень());

ВыборкаДетали = ВыборкаОбщийИтог.Выбрать();

Пока ВыборкаДетали.Следующий() Цикл
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетали);
ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетали.Уровень());
КонецЦикла;

ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.Вывести(ОбластьПодвалТаблицы);
ТабДок.Вывести(ОбластьПодвал);
//Без конструктора
//ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;
// ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабДок.НижнийКолонтитул.Выводить = Истина;
ТабДок.НижнийКолонтитул.НачальнаяСтраница = 1;
// ТабДок.НижнийКолонтитул.ТекстСлева = " № " + Номер;
ТабДок.НижнийКолонтитул.ТекстСправа = "стр. "+"[&НомерСтраницы]"+" из "+"[&СтраницВсего]";

//}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ


Профессионалы! Мне кто-нибудь подскажет в чем проблема - почему не печатается шапка на каждой странице? 777нуждаюсь в помощи!!!
Guest 777нуждаюсь в помощи!!! 777нуждаюсь в помощи!!! Помогите изменить макет чтобы печаталась шапка:
Процедура ТипыСчетчиковОбщееСортирвка(ТабДок) Экспорт
//{{КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ(ТипыСчетчиковОбщееСортирвка)
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Макет = ОтчетОбъект.ПолучитьМакет("ТипыСчетчиковОбщееСортирвка");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|......
|АВТОУПОРЯДОЧИВАНИЕ";

Результат = Запрос.Выполнить();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
ОбластьОбщийИтог = Макет.ПолучитьОбласть("ОбщиеИтоги");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

ТабДок.Очистить();
ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаОбщийИтог = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

ВыборкаОбщийИтог.Следующий(); // Общий итог
ОбластьОбщийИтог.Параметры.Заполнить(ВыборкаОбщийИтог);
ТабДок.Вывести(ОбластьОбщийИтог, ВыборкаОбщийИтог.Уровень());

ВыборкаДетали = ВыборкаОбщийИтог.Выбрать();

Пока ВыборкаДетали.Следующий() Цикл
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетали);
ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетали.Уровень());
КонецЦикла;

ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.Вывести(ОбластьПодвалТаблицы);
ТабДок.Вывести(ОбластьПодвал);
//Без конструктора
//ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;
// ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабДок.НижнийКолонтитул.Выводить = Истина;
ТабДок.НижнийКолонтитул.НачальнаяСтраница = 1;
// ТабДок.НижнийКолонтитул.ТекстСлева = " № " + Номер;
ТабДок.НижнийКолонтитул.ТекстСправа = "стр. "+"[&НомерСтраницы]"+" из "+"[&СтраницВсего]";

//}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ


Профессионалы! Мне кто-нибудь подскажет в чем проблема - почему не печатается шапка на каждой странице?
Получается глюк в 8-ке и строка
ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;
совсем не означает что будет вывод шапки на каждой странице? Господин ПЖ
Member [заблокирован]
Откуда:
Сообщений: 5765
777нуждаюсь в помощи!!! 777нуждаюсь в помощи!!! 777нуждаюсь в помощи!!! Помогите изменить макет чтобы печаталась шапка:
Процедура ТипыСчетчиковОбщееСортирвка(ТабДок) Экспорт
//{{КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ(ТипыСчетчиковОбщееСортирвка)
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Макет = ОтчетОбъект.ПолучитьМакет("ТипыСчетчиковОбщееСортирвка");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|......
|АВТОУПОРЯДОЧИВАНИЕ";

Результат = Запрос.Выполнить();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
ОбластьОбщийИтог = Макет.ПолучитьОбласть("ОбщиеИтоги");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

ТабДок.Очистить();
ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаОбщийИтог = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

ВыборкаОбщийИтог.Следующий(); // Общий итог
ОбластьОбщийИтог.Параметры.Заполнить(ВыборкаОбщийИтог);
ТабДок.Вывести(ОбластьОбщийИтог, ВыборкаОбщийИтог.Уровень());

ВыборкаДетали = ВыборкаОбщийИтог.Выбрать();

Пока ВыборкаДетали.Следующий() Цикл
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетали);
ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетали.Уровень());
КонецЦикла;

ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.Вывести(ОбластьПодвалТаблицы);
ТабДок.Вывести(ОбластьПодвал);
//Без конструктора
//ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;
// ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабДок.НижнийКолонтитул.Выводить = Истина;
ТабДок.НижнийКолонтитул.НачальнаяСтраница = 1;
// ТабДок.НижнийКолонтитул.ТекстСлева = " № " + Номер;
ТабДок.НижнийКолонтитул.ТекстСправа = "стр. "+"[&НомерСтраницы]"+" из "+"[&СтраницВсего]";

//}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ


Профессионалы! Мне кто-нибудь подскажет в чем проблема - почему не печатается шапка на каждой странице?
Получается глюк в 8-ке и строка
ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;
совсем не означает что будет вывод шапки на каждой странице?

>>Получается глюк в 8-ке

ИМХО Глюк с прочтением хелпа у вас. Выводить надо не секцию макета "ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;", а область полученную после вывода этой секции в таб. документ. Т.е.

лСекцияПовтора = ТабДок.Вывести(ОбластьШапкаТаблицы); ТабДок.ПовторятьПриПечатиСтроки = лСекцияПовтора; Алексей Р.
Member
Откуда:
Сообщений: 304
777нуждаюсь в помощи!!!
Получается глюк в 8-ке и строка
ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;
совсем не означает что будет вывод шапки на каждой странице?

Никакого глюка нет все нормально работает.

Думаю у вас ошибка в том, что вы присваиваете к ПовторятьПриПечатиСтроки область из другого макета

У меня вот это работает:

Область = Макет.ПолучитьОбласть(НаимОблЗаголовков); ВысотаЗаголовков = Область.ВысотаТаблицы; ТабДок.ПовторятьПриПечатиСтроки = ТабДок.Область(ТабДок.ВысотаТаблицы + 1,,ТабДок.ВысотаТаблицы + 1 + ВысотаЗаголовков - 1,); 777нуждаюсь в помощи!!!
Guest Господин ПЖ 777нуждаюсь в помощи!!! 777нуждаюсь в помощи!!! 777нуждаюсь в помощи!!! Помогите изменить макет чтобы печаталась шапка:
Процедура ТипыСчетчиковОбщееСортирвка(ТабДок) Экспорт
//{{КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ(ТипыСчетчиковОбщееСортирвка)
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Макет = ОтчетОбъект.ПолучитьМакет("ТипыСчетчиковОбщееСортирвка");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|......
|АВТОУПОРЯДОЧИВАНИЕ";

Результат = Запрос.Выполнить();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
ОбластьОбщийИтог = Макет.ПолучитьОбласть("ОбщиеИтоги");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

ТабДок.Очистить();
ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаОбщийИтог = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

ВыборкаОбщийИтог.Следующий(); // Общий итог
ОбластьОбщийИтог.Параметры.Заполнить(ВыборкаОбщийИтог);
ТабДок.Вывести(ОбластьОбщийИтог, ВыборкаОбщийИтог.Уровень());

ВыборкаДетали = ВыборкаОбщийИтог.Выбрать();

Пока ВыборкаДетали.Следующий() Цикл
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетали);
ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетали.Уровень());
КонецЦикла;

ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.Вывести(ОбластьПодвалТаблицы);
ТабДок.Вывести(ОбластьПодвал);
//Без конструктора
//ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;
// ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабДок.НижнийКолонтитул.Выводить = Истина;
ТабДок.НижнийКолонтитул.НачальнаяСтраница = 1;
// ТабДок.НижнийКолонтитул.ТекстСлева = " № " + Номер;
ТабДок.НижнийКолонтитул.ТекстСправа = "стр. "+"[&НомерСтраницы]"+" из "+"[&СтраницВсего]";

//}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ


Профессионалы! Мне кто-нибудь подскажет в чем проблема - почему не печатается шапка на каждой странице?
Получается глюк в 8-ке и строка
ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;
совсем не означает что будет вывод шапки на каждой странице?

>>Получается глюк в 8-ке

ИМХО Глюк с прочтением хелпа у вас. Выводить надо не секцию макета "ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;", а область полученную после вывода этой секции в таб. документ. Т.е.

лСекцияПовтора = ТабДок.Вывести(ОбластьШапкаТаблицы); ТабДок.ПовторятьПриПечатиСтроки = лСекцияПовтора;
//Без конструктора
//ТабДок.Вывести(ОбластьШапкаТаблицы);
лСекцияПовтора = ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.ПовторятьПриПечатиСтроки = лСекцияПовтора;
///////////////////////ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;
ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
ТабДок.НижнийКолонтитул.Выводить = Истина;
печатает 1 раз в конце документа, т.е. не на каждой странице вверху, а просто самой последней строкой на самом последнем листе Алексей Р.
Member
Откуда:
Сообщений: 304
Для проверки попробуй
ТабДок.ПовторятьПриПечатиСтроки = ТабДок.Область(1,,10,); 777нуждаюсь в помощи!!!
Guest Алексей Р. Для проверки попробуй
ТабДок.ПовторятьПриПечатиСтроки = ТабДок.Область(1,,10,);
Алексей Р. Спасибо! Ваш вариант заработал! А вот другие меня смогли захаить а правильного варианта дать не смогли! Так что Алексей Р. Вы единственный кто знает ответ на этот вопрос! Респект и Уважение! Спасибо! Между сообщениями интервал более 1 года.
Djony Otan
Guest тебе еще раньше дали правильный ответ !

ИМХО Глюк с прочтением хелпа у вас. Выводить надо не секцию макета "ТабДок.ПовторятьПриПечатиСтроки = ОбластьШапкаТаблицы;", а область полученную после вывода этой секции в таб. документ. Т.е.

лСекцияПовтора = ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.ПовторятьПриПечатиСтроки = лСекцияПовтора;

athom45
Member
Откуда:
Сообщений: 2
ОбластьПовтор = Макет.ОБЛАСТЬ("Повтор"); //а не ПолучитьОбласть()

ТабДок.ПовторятьПриПечатиСтроки = ОбластьПовтор;

athom45
Member
Откуда:
Сообщений: 2
В построителе:
ОбластьПовтор = ПостроительОтчетаОтчет5.Макет.ОБЛАСТЬ("ШапкаТаблицы");
ЭлементыФормы.ПолеТабличногоДокумента.ПовторятьПриПечатиСтроки = ОбластьПовтор ; Виртуальные форумы   Темы из всех форумов за 3 дня   Мои избранные форумы Использование СУБД   Microsoft SQL Server   Firebird, InterBase   Oracle   Microsoft Access   IBM DB2, WebSphere, IMS, U2, etc   MySQL   PostgreSQL   OLAP и DWH   Sybase ASA, ASE, IQ   Informix   Другие СУБД   FoxPro, Visual FoxPro   Caché, Ensemble, DeepSee, MiniM, IRIS, GT.M   SQLite   NoSQL, Big Data Дискуcсии   Сравнение СУБД   Проектирование БД   Работа   ERP и учетные системы   Разработка информационных систем   Тестирование и QA   Отчетные системы   Просто треп   Наши за рубежом   Сертификация и обучение   Hardware   Управление процессом разработки ИС   Юридические вопросы в ИТ Microsoft.NET   WinForms, .Net Framework   ASP.NET   ADO.NET, LINQ, Entity Framework, NHibernate, DAL, ORM   WPF, Silverlight   WCF, Web Services, Remoting Программирование   Delphi   C++   Visual Basic   Программирование   Java   Разработка под мобильные платформы   PowerBuilder   Microsoft Office   SharePoint   XML, XSL, XPath, XQuery Web Технологии   PHP, Perl, Python   HTML, JavaScript, VBScript, CSS Администрирование ОС   Windows   Unix-системы   Другие: Mac OS, PalmOS, BeOS, PocketPC SQL.RU   Обсуждение нашего сайта   Вопрос-Ответ   Test
Как сделать чтобы шапка печаталась на каждой страницеКак сделать чтобы шапка печаталась на каждой страницеКак сделать чтобы шапка печаталась на каждой страницеКак сделать чтобы шапка печаталась на каждой страницеКак сделать чтобы шапка печаталась на каждой страницеКак сделать чтобы шапка печаталась на каждой страницеКак сделать чтобы шапка печаталась на каждой страницеКак сделать чтобы шапка печаталась на каждой страницеКак сделать чтобы шапка печаталась на каждой страницеКак сделать чтобы шапка печаталась на каждой страницеКак сделать чтобы шапка печаталась на каждой страницеКак сделать чтобы шапка печаталась на каждой страницеКак сделать чтобы шапка печаталась на каждой страницеКак сделать чтобы шапка печаталась на каждой страницеКак сделать чтобы шапка печаталась на каждой странице Как очистить позолоту в домашних условияхКак сделать волшебное заклинаниеКогда высаживать рассаду помидорКак сделать так чтобы messageКак сделать босса ктулхуНеобычные идеи на день рождения своими рукамиКак сшить платье рыбкойРисунки для мамы на день рождения своими рукамиКороткое поздравление для молодых в прозеКладка декоративного кирпичная своими рукамиКрасивый цветок для вышивкиКак сделать презентации с эффектамиВыращивание пионов из семянСшить бант на детское платьеРододендрон с кем сажать